Patrol 4x4 - Nissan Patrol Forum banner
1 - 9 of 9 Posts

·
Registered
nissan
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey guys i have an 01 3litre patrol that i brought with a blown no. 4 piston and 150000ks on the clock. i have since fixed the motor using a full engine rebuild kit and fitted a brand new turbo and blocked the egr. i have the dawes valve setup on it 3inch exhaust and egt and boost gauges. i got it up and running on the weekend and set the dawes valve etc up and it boosts straight up to 16psi boost and stays there without spiking but the car is still very gutless and the egts dont rise over 250 degrees which points me in the directing that the engine is not getting enough fuel. has anyone else had this problem or have any ideas to help me out.

Much appreciated
 

·
united fuel injection
Nissan
Joined
·
2,633 Posts
Hey guys i have an 01 3litre patrol that i brought with a blown no. 4 piston and 150000ks on the clock. i have since fixed the motor using a full engine rebuild kit and fitted a brand new turbo and blocked the egr. i have the dawes valve setup on it 3inch exhaust and egt and boost gauges. i got it up and running on the weekend and set the dawes valve etc up and it boosts straight up to 16psi boost and stays there without spiking but the car is still very gutless and the egts dont rise over 250 degrees which points me in the directing that the engine is not getting enough fuel. has anyone else had this problem or have any ideas to help me out.

Much appreciated
Did you replace the Air Flow Meter?????
 

·
Registered
nissan
Joined
·
502 Posts
i could be wrong but 16pound sounds a little high for that motor especislly being new. and yeah i would be having the fuel checked before starting it again
 

·
Registered
Joined
·
63 Posts
Any codes?
like toughdiesels said try replacing MAF and go from there.
 

·
Registered
nissan
Joined
·
4 Posts
Discussion Starter · #5 ·
no havent done the maf yet. i thought this may possibly be the fault just thought i would ask the question first to see if anyone else had the same symptoms
 

·
Registered
Nissan
Joined
·
341 Posts

·
ZD30 Out - L77 In!
nissan patrol
Joined
·
3,352 Posts
i could be wrong but 16pound sounds a little high for that motor especislly being new. and yeah i would be having the fuel checked before starting it again
Yeh, I agree. I’d be using 15psi on a single Dawes setup unless you slow the spooling right down. It shouldn’t matter how new the engine is and you may not get an MIL or any codes, but if you’re getting good boost and then nothing, it may be going into failsafe mode and loosing all power. If the initial throttle response is good, but then it dies, that could be your problem.
 
1 - 9 of 9 Posts
Top