Patrol 4x4 - Nissan Patrol Forum banner

1 - 4 of 4 Posts

·
Registered
Nissan
Joined
·
1 Posts
Discussion Starter #1
Im having problems with breaks.
Ive been to a garage and they said it was the abs breaks and when they checked the abs were fine...
I have no problems when breaking and the car stops fine, when applying the breaks to slow down the car makes a weird noise and feels like it moves... Now it only makes a noise when I am slowing down at a speed between 15/20 kmph. When slowing down at any other speeds its fine but ones it hits 20kmph then the problems with movement and sound come in.

thanks
 

·
Registered
Joined
·
451 Posts
Long time ago but I had a similar experience with loose caliper slide/guide bolts. Once tightened no further problems.
 

·
Administrator
Y2KGUII ZD Wgn
Joined
·
48,213 Posts
Im having problems with breaks.
Ive been to a garage and they said it was the abs breaks and when they checked the abs were fine...
I have no problems when breaking and the car stops fine, when applying the breaks to slow down the car makes a weird noise and feels like it moves... Now it only makes a noise when I am slowing down at a speed between 15/20 kmph. When slowing down at any other speeds its fine but ones it hits 20kmph then the problems with movement and sound come in.

thanks
Mate you have posted in Classic Nissan Patrols and I don't know to many of them that have ABS, give us some info on your vehicle and I will move it to the appropriate section.

As Porks says it could be something loose, but it could also be something seizing. Are you gatting any feedback through the pedal or steering wheel?
 

·
Master Coalroller
nissan
Joined
·
3,230 Posts
X2 the back disk caliper sliders are famous for making a humph humph noise when old.

And

X2 it's not a classic if it's got ABS. I was hoping to open this thread and be reading about a G60
 
1 - 4 of 4 Posts
Top