Patrol 4x4 - Nissan Patrol Forum banner

1 - 4 of 4 Posts

·
Registered
nissan patrol
Joined
·
3 Posts
Discussion Starter #1
hi everyone, i have a 94 rx efi 4.2lt 5 sp man wagon on both gas and petrol, over the last few months i have noticed a kind of rattling noise coming from the engine bay when the car is under load but this only happens on petrol not on gas? at first i thought this could be a bearing or somthing in the gearbox/clutch area but being that this noise instantly stops when i turn it to gas it has made me wonder, the noise doesnt appear when it is in neutral so i cant just rev it in the driveway and listen where the noise might be.
i was wondering if anyone else has had this problem i thought maybe it is unique to injected models? just a theory as ive had a few carby models and never come accross this.
thanks dave
 

·
Registered
Joined
·
1 Posts
I Have heard this weird rattling noise also on my 1992 ti nissan wagon 4.2 efi 5 sp manual, mine shows up if the ignition is left on for a while sitting in the garage with swith to autogas on
its a little vacuum thingy on the battery side, maybe something to do with petrol or autogas pressure, but hav not heard it for a while !
Also my patrol cranks for a while trying to start on autogas so i start with it on petrol for a solve.
Also another thing the gas mechanic found i had a bad earth screw wire connection on the switch over valve, so i sandpapered the connector and tighned it up and have not heard that rattle for quiet some time,
try that fix dave
good luck
Lance
 

·
I Have Imaginary Friends
Patrol Hybrid.
Joined
·
15,547 Posts
Dave hasn’t been on here since 22/2/2012.
 
1 - 4 of 4 Posts
Top