Patrol 4x4 - Nissan Patrol Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
Gday! Just got back into another gq and it’s rb30 efi been converted into a 97 rd28, loving it so far but more power then the old na td42 but fuel economy is shocking obviously.. my issue I’m having is when I start it etc it has a real heavy smell of fuel like it’s dumping more fuel in etc I’m unsure. The temp gauge doesn’t work would this be the reason it’s doing this as the ecu isn’t reading the cars cold or hot?, I’ve noticed the temp senser on the engine is snapped off but if I replaced that would the thing even work as it’s been converted from Rd to rb? Has r31 engine loom from what I’m told and all the dash loom etc is standard, do all the dash looms in the Rd and rb work together? Fuel gauge, bolts and oil pressure is all good but temp is my issue. Cheers
Tire Wheel Automotive parking light Automotive side marker light Sky
 

· Registered
Joined
·
32 Posts
Discussion Starter · #3 ·
Cheers mate. Has the standard 4.6 diffs on 33inch tires and I get 20ltr per 100 and I’ll give it a go with injector cleaner etc, on the rb30 there’s 2 sensers on the top of the engine ones the ecu and the others the temp but that’s snapped off. I was just wondering if I’d have to change anything else in the wiring for the temp gauge to work (other then fixing the senser) all other gauges work but the rev range on the dash and the temp. I’ll give this all a go and hopefully there’s nothing needed to be wired in or changed for it all to work.
 
1 - 2 of 2 Posts
Top