Patrol 4x4 - Nissan Patrol Forum banner

1 - 4 of 4 Posts

Registered
Joined
641 Posts
Discussion Starter #1
Got my bus back. Didn't really get a chance to test over weekend.
Key's broke on Mums car, had to take Bus.
Car was juddering at low revs many times. Read:
Possible maf sensor problem.
ZD30 owners said don't pull it out or you'll be soldering all night.

Unscrewed, pulled. Broken connections.....
Whatever, we all make mistakes.
Now I'd like to know if I can drive 50 clicks or more based on experience tomorrow until I pull the entire unit off?

Best, thanks. 馃憤 馃嵑
 

Registered
1998 2.8GU wagon
Joined
2,294 Posts
It will be Ok to drive, it will just be down on power & use a bit more fuel. When you've repaired it, paint the screw heads with red paint to remind yourself not to do it again. Put enough paint on so that you can't get a screwdriver into them.
 

Registered
Joined
641 Posts
Discussion Starter #3
Thanks Woolly.
Turned out ok. Still hafta fixit. Poured today, last night.
Then the starter died. Go figure.
Thank you.
Be well.
馃嵑


It will be Ok to drive, it will just be down on power & use a bit more fuel. When you've repaired it, paint the screw heads with red paint to remind yourself not to do it again. Put enough paint on so that you can't get a screwdriver into them.
 

Registered
Joined
641 Posts
Discussion Starter #4
Since I couldn't find a single image regarding this fix. I've uploaded the fix.
Would have been real handy to know that there is a sealed lid on top to save removing the whole assembly.
Alrighty then. Images didn't upload.
I'll place them then on my site.
Thanks woolly.
Be well man 馃憤馃嵑
 
1 - 4 of 4 Posts
Top