Patrol 4x4 - Nissan Patrol Forum banner

1 - 4 of 4 Posts

·
Registered
nissan patrol gq
Joined
·
1,685 Posts
Discussion Starter #1 (Edited)
Currently doing an engine conversion on a TB48 with the 5 speed automatic gearbox, changing it to a TD42 and want to keep the 5 speed auto in it.

The gearbox needs to communicate with the engine ECU via CANBUS otherwise it doesn't work, I'm hoping someone may be able to offer some tips regarding preventing limp mode from activating due to the ECU not necessarily getting enough info from the "engine", we're going to setup as many of the inputs from the engine as possible, including maintaining the TPS on the pedal, engine temp, engine speed and gearbox speed and such.

We're expecting to throw some interesting codes due to the ECU not having an actual engine control, what we want to avoid though is the gearbox going into a limp mode.

We've contacted a most places regarding stand alone gearbox computers in Australia who say you cannot get one for that gearbox, we've emailed the states and Japan with similar results, we keep getting told the gearbox cannot be run without communicating with the ECU, Japan offered to re-programme the gearbox computer to run in a different car, but it still needs an ECU which the TD42 obviously doesn't have. We are now looking at the option of tricking the ECU into thinking it's working so that the gearbox will operate correctly.

So my question is, has anyone had any experiences in tricking the ECU to prevent limp mode from coming on, or what codes thrown by the ECU will cause a limp mode so that maybe we can over come them.

Edit: the gearbox model is a RE5R05A
 

·
Registered
nissan y61
Joined
·
4,788 Posts
Talk to these people they Wizards on JATCO box and have standalone ECU's. TRANSCO TELL 001 626 443 7451
TransGo-Home Page
 

·
Registered
nissan
Joined
·
198 Posts
i looked into stand alone ecu's for the gearbox when i turboed the 4.8. my tuner had a supplier for the ecu and was confident he could get it to stand alone. nothings impossible its just a gearbox after all
 

·
Registered
nissan y61
Joined
·
4,788 Posts
If the RE5 JATCO Box does go in limp mode the A/T flashes and lock in 3rd gear. So I don't think limp mode will be you problem what will be your problem is the shift pattern needed for the 5SP to work correctly. Just unplugging the speed sensor on this box makes it hang in the gears but that is due to ECU of engine and not the ECU of 5spd. Im sure it can be done and Mr Shift will know how.

Most problems are from the wrong ATF been used, lushing it and not filling it correctly. I must admit even the manual is not very good at helping in this issue. Its not correct as they say "drain sump oil and replace WITH the same amount drained" Now if that level is wrong what good is that.

It should. During a cold check make sure the level is correct before draining the ATF level. Just 350ml over or 500ml under results in some funny clonks and knocks when going into R or D.
 
1 - 4 of 4 Posts
Top