Patrol 4x4 - Nissan Patrol Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
387 Posts
Discussion Starter #1
Hi all,

2001 GUII - My electric antenna has died. Can I get any powered antenna, or does the multi-position switch on the dash only work with a Nissan one? I'm keen to keep the switchable option so I can flick a button and not loose the antenna when scrub bashing, but I presume Nissan will charge big $$$ if I need to go genuine!?!

It can be manually positioned anywhere between about 3/4 of the way down and fully up, but when you turn the car on / off, you can hear the motor working for about 20 secs with a clicking sound (sounds like gears slipping), but without the antenna moving. I'm therefore pretty sure that the electrics are all working right, but the gearing between the antenna motor and the antenna itself are shot. I therefore presume it's a throw away and replace job, unless anyone has repair suggestions?

Thanks,
 

·
It's all good
nissan patrol
Joined
·
4,171 Posts
No sure about needing to be replaced , give nizzbits on here a shout he may be able to help , my aerial is bent from bushings but still goes up and down
 

·
Registered
nissan
Joined
·
2,003 Posts
Try replacing the "mast and rope"... only about $50 or so and a 5 minute job.

The motor is obviously working OK. Even if you just get it to spit out the old mast and check the wear on the "rope" which is actually placcy cable with teeth that are driven by the motor.

All you do is undo the chrome nut on the Antenna Assy (on top of the guard) and power it "up" and with maybe a gentle pull to help it will spit out the mast.
 

·
Registered
nissan
Joined
·
645 Posts
I have looked into replacing my mast as it got bent even when half way down, (Also broke my bro-in-laws uhf aerial on the same trip). They cost $90.
 

·
Currently in PAD rehab
Joined
·
18,639 Posts
Mine wouldnt go all the way down a while ago, and made that clicking noise. All i did was to turn the ignition off, wait for it to give up clicking, and then manually push it all the way down. When i turn the ignition on, it came all the way up, ignition off, all the way back down.

I have no idea technically what was wrong, or what i did, but it seemed to fix it.
 

·
Registered
nissan
Joined
·
2,003 Posts

·
Registered
Joined
·
387 Posts
Discussion Starter #7
Thanks guys, I can manually move it up or down, but the motor doesn't move it at all anymore. I'll try the rope 1st as suggested. Thanks,
 

·
Registered
Nissan
Joined
·
583 Posts
I tried the rope and it lasted about two weeks not worth it imo :headwall:
 

·
Registered
nissan patrol gu 2000
Joined
·
1 Posts
Hi Guys

I have a similar problem with my 2000 GU Patrol.

The only issue is that the antennae won't pop up at all (just grinding noises from the motor). So I can't just "pull" it out.

it seems to be stuck in it's plastic sleeve.

Any help would be appreciated.
 

·
Registered
Joined
·
1,873 Posts
I have just snapped mine for the 2nd time, accountant won't be happy, I've done the rope replacement before but has anyone changed to a fixed rubber type as yet. It was in lower position but didn't see vine hangi g down.
 
1 - 10 of 10 Posts
Top