Patrol 4x4 - Nissan Patrol Forum banner
1 - 20 of 26 Posts

·
Registered
nissan patrol
Joined
·
817 Posts
Discussion Starter · #1 ·
Thought it was time I put my new GQ in here.
This one is getting set up to tour oz in the near future.
I bought this car with a blown motor it did the rear main lost all oil pressure then spun a big end bearing.
It’s a 1990 td42
Fully rebuilt motor
Switzer turbo with water to air intercooler
21/2 inch exhaust
Hella rallye 4000 converted to hid
Hid head lights
dual batts with a 200ah gel battery
2x 40l waecos
alloy roof cage with 2x18w led lights each side






this is the motor before it went in the car with the turbo bolted up


engine in with ic plumbed up




water cooler for ic


this is a gauge pod i made


something to keep the beers cold or the pies hot


this is the mess i pulled out of it whin i got it


things to still do
2" lift kit
33" mt fcii's
make rear storage system to fit battery and fridges
get it dyno tuned
clear coat affected paint areas.

cheers
Roddo
 

·
Registered
nissan patrol
Joined
·
817 Posts
Discussion Starter · #3 ·
yeah i reckon
its taken me a while and im still having a few teathing issues.
its really hard to start for some reason but once running she runs like a dream and has heaps of power.
 

·
Registered
nissan patrol
Joined
·
817 Posts
Discussion Starter · #5 ·
yeah i hope i do. yeah prob should change the sig as i no longer have that car.
 

·
Registered
nissan patrol
Joined
·
817 Posts
Discussion Starter · #8 ·
drilled a hole on the side of the roof at the back of each side right behing the upright suports on the rack and used a grommet. didnt really want to drill into the car but couldnt fint another way.
 

·
Registered
nissan
Joined
·
502 Posts
looking good mate ill be following this one im lookin at doing a few trips next year an need some good ideas.
 

·
Registered
nissan patrol
Joined
·
817 Posts
Discussion Starter · #10 ·
finally sorted out my starting problems.
it was the starter motor and the aftermarket ryco fuel filter.
put the factory filter back on and cleaned the starter motor out and replaced the solinoid.
now it starts on the 1st or second turn everytime.
 

·
Registered
nissan
Joined
·
448 Posts
yeah i reckon
its taken me a while and im still having a few teathing issues.
its really hard to start for some reason but once running she runs like a dream and has heaps of power.
Taken a while?

when I saw it, it looked a lot worse and that wasn't very long ago at all!

Cooler looks good I like it man.

What was the cause of the starting issues?
 

·
Registered
nissan patrol
Joined
·
817 Posts
Discussion Starter · #13 ·
it was the starter motor
pulled it appart cleaned it re greased it new solonoid and she spins up super fast now.
 

·
Registered
nissan patrol
Joined
·
817 Posts
Discussion Starter · #14 ·
well i finally wired up the side roof rack lights and my reversing lights on a ferret twin light bracket.
 

Attachments

·
Registered
nissan patrol
Joined
·
817 Posts
Discussion Starter · #16 ·
yeah i might look into them in the next few weeks
 
1 - 20 of 26 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top