Patrol 4x4 - Nissan Patrol Forum banner

1 - 13 of 13 Posts

·
Registered
nissan
Joined
·
52 Posts
Discussion Starter #1
Hey just wanted to no has any one had a problem with ryco fuel filters on a zd30 because after changing to a ryco yesterday when I start my car it runs really rough and blowing smoke for about 10 seconds then its fine no smoke and runs good. If I turn the car off after it was running rough and start it again its fine not rough and no smoke leave it for 10 minutes and start it runs rough and blows smoke. Can not work it out
 

·
Registered
nissan
Joined
·
52 Posts
Discussion Starter #5
Doubt it, The ryco fuel filter is pretty close to OEM filter spec, prolly the best to use
other than OEM .
Make sure your release point near the injectors, is the highest you can find.
I'm not sure what you mean by release point near the injectors in the highest I can fine. The way I changed the filter was I took both lines off and blocked them removed old filter got new filter and filled with diesel before putting on hooked up line closest to drivers window pumped until a solid stream of diesel came though then hooked up second line and pumped until it went hard got a friend to start the car and I keeper pumping left car running for 2 minutes then turned if off.
 

·
Registered
nissan
Joined
·
52 Posts
Discussion Starter #7
Agreed, air in your system, some where. I run the ryco fuel filters and have never had issues.
How can I get the air out I took the filter off just before and tryed bleeding it again with no luck running bad alot of white smoke turn off and turn on starts great but still smoke for about 5 minutes.leave car for five minutes turned off and start again same problem again run rough and white smoke
 

·
Registered
nissan
Joined
·
4,454 Posts
Check your hose connections are tight, your filter is on strait and tight and you have no splits in the hoses.
 

·
Registered
nissan patrol
Joined
·
305 Posts
Mate i think you have air right through the system. If the air lock was that bad on mine i would crack open the injectors and then prime the pump till all the air is out but mine is a 4.2.

I dont know weather is the same for the 3L
 

·
Registered
nissan patrol
Joined
·
315 Posts
deffinatley air. start it and crack each injector. one, if not all will have air bubbles. nip them again while the engine is running.
 

·
Registered
nissan
Joined
·
52 Posts
Discussion Starter #11
found problem was not air in the fuel. came home from work to day after getting a lift from my brother and tryed starting the patrol no luck motor locked water on the floor cracked head or blown head gasket. just my luck.
 
1 - 13 of 13 Posts
Top