Patrol 4x4 - Nissan Patrol Forum banner
21 - 31 of 31 Posts

·
Registered
2004 Nissan Patrol GU Y61 ZD30 DI
Joined
·
80 Posts
Discussion Starter · #21 ·
thanks heaps mate I’ll switch them over tomorrow

Doing it now. There are two black wires with yellow trace though. One is thicker with two yellow stripes and the other is thinnner with single yellow stripe
correction: they both have two stripes.
is it thin or thicker one I connect to?
thanks heaps mate I’ll switch them over tomorrow

Doing it now. There are two black wires with yellow trace though. One is thicker with two yellow stripes and the other is thinnner with single yellow stripe
The one you need will more than likely be the smaller one. You will need to check to confirm. It needs to have power when the ignition switch is on.

The second one I think will only have power when you turn the key to start.
Awesome thanks heaps for your help
 

·
Registered
2004 Nissan Patrol GU Y61 ZD30 DI
Joined
·
80 Posts
Discussion Starter · #22 ·
So it’s working as it should, it didn’t like the bigger black and yellow and ran something loud that sounded like a fan when I turned the ignition off. So connected to the smaller one and the timer is working perfectly. I do have the sub tank issue though
 

·
Premium Member
Y62
Joined
·
2,636 Posts
So it’s working as it should, it didn’t like the bigger black and yellow and ran something loud that sounded like a fan when I turned the ignition off. So connected to the smaller one and the timer is working perfectly. I do have the sub tank issue though
It's possible you have logged a fault with the sub tank module. Disconnect the battery for half an hour or so and see if that resets the subtask light.
 

·
Premium Member
Y62
Joined
·
2,636 Posts
The timer is running fine but the sub tank issue is still there. Trying to research some different solutions
So after you disconnected the battery and started the vehicle the sub tank light was out? But after the vehicle was shut down by the timer the sub tank light was on again next time you started the vehicle?
 

·
Registered
nissan
Joined
·
848 Posts
Its easy to modify the subtank module to auto reset every time the car shuts down, thats what I did and I havnt had a problem for the 10 years since.
 

·
Registered
2004 Nissan Patrol GU Y61 ZD30 DI
Joined
·
80 Posts
Discussion Starter · #28 ·
So after you disconnected the battery and started the vehicle the sub tank light was out? But after the vehicle was shut down by the timer the sub tank light was on again next time you started the vehicle?
Yeah if I disconnect the battery it resets but comes on pretty soon after starting the car
 

·
Premium Member
Y62
Joined
·
2,636 Posts
Yeah if I disconnect the battery it resets but comes on pretty soon after starting the car
That’s not the answer I was expecting.

There’s mods that can be done such as using a diode to power up the accessory circuit or changing the battery feed to the sub tank module to an ignition feed to make it do a reset every time the vehicle is started, but I don’t think these will help in your case, if the light is coming on while you are driving.

Try moving the shut down timers Blue wire from the Black wire with a Yellow trace and connect it to the Black wire with a White trace and see if that changes things. Disconnect the battery to reset the sub tank module again.
 

·
Registered
2004 Nissan Patrol GU Y61 ZD30 DI
Joined
·
80 Posts
Discussion Starter · #30 ·
That’s not the answer I was expecting.

There’s mods that can be done such as using a diode to power up the accessory circuit or changing the battery feed to the sub tank module to an ignition feed to make it do a reset every time the vehicle is started, but I don’t think these will help in your case, if the light is coming on while you are driving.

Try moving the shut down timers Blue wire from the Black wire with a Yellow trace and connect it to the Black wire with a White trace and see if that changes things. Disconnect the battery to reset the sub tank module again.
Thanks I’ll give that a go. I read up on some of the soloutions like a diode or a relay but couldn’t understand well enough to try.. my electronics vocabulary is basically plug, wire and that thing
 

·
Registered
2004 Nissan Patrol GU Y61 ZD30 DI
Joined
·
80 Posts
Discussion Starter · #31 ·
Thanks I’ll give that a go. I read up on some of the soloutions like a diode or a relay but couldn’t understand well enough to try.. my electronics vocabulary is basically plug, wire and that thing
[/QUOTE
Hey I switched the blue wire from the black/yellow to the black/white and that has fixed it 👍
Thanks heaps for all your help
 
21 - 31 of 31 Posts
Top