Patrol 4x4 - Nissan Patrol Forum banner

1 - 4 of 4 Posts

·
Registered
nissan
Joined
·
3 Posts
Discussion Starter #1
Guday all I've got a small issue with my safari. Doesn't have power to the diesel pump I've checked all the obvious fuses relays even took the diesel shut off slide out and still no go I un done injectors try cranking it no diesel pumping. Traced it back to second solenoid as shut off solenoid has power second one on top has none, it's like a banjo nut with a small filter in it with a terminal like the fule solenoid. Does this need power?
I'm out of ideas at moment starting to think it's computer??? Its 24 volt safari only done 150k cost me a packet too. Now going no where Any ideas cheers.
 

·
Registered
Joined
·
14 Posts
I had a similar problem where the engine would cut out and not start again.

What my problem was is there are two wires that splice into one and they were touching on/off. The wires are from the glow plug relays and therefore not supplying current to the fuel cut solenoid. It is a common Safari problem.

You have to unpeal the electrical tape and loom behind the driver side battery just before it goes into the relay box (behind said battery). From memory the wires are purple and they will have a dodgy wrap around splice 2 wires into 1.

Give that a try.
 

·
Registered
Joined
·
24 Posts
Thanks. i dont have power coming from the glow control unit. I have 3v on a small white with red trace coming into it and nothing coming out. No glow lamp either.
 
1 - 4 of 4 Posts
Top