Patrol 4x4 - Nissan Patrol Forum banner
1 - 10 of 10 Posts

·
Registered
nissan/patrol
Joined
·
45 Posts
Discussion Starter · #1 ·
gday guys, few qquestions,
the weekend gone, i built my self a set of rear drawers, and a sub and amp in the small triangle gap between the seats,

since doing this when i have the sub pumpin and music going, there seeems to be a funny electric smell coming from it,

its all wired up properly, the sub was previously in another car of mine and didnt have any dramas,

i am thinking dust? but it only seems to happen when it is turned right up,,


any thoughts/ suggestions would be great, thanks in advance.
 

·
The nutty professor
Joined
·
8,299 Posts
im thinking you are burning out the coil in your sub,

did something similar a few years ago when i built myself a set of home subs and was testing them out with a frequency test................sounded awsome then i noticed a funny smell and smoke comming from the subs...
 

·
Registered
Joined
·
83 Posts
could be givin your amp too much stick and cooking it, or cooking your sub for the same reason. if youve enclosed your amp too it may be heating up real quick with all the power its recieving. when you smell it, stop the music so you dont kill your ears, and put your hand on the amp if you can get to it and see if its hot or not.

on a side note, with speaker enclosures you gotta get them to an optimal volume regardless of the shape so you get optimal volume. get that right and youll find you use less power to create better sound too. good luck with it ey!!!
 

·
Registered
Joined
·
305 Posts
Your cooking your sub, did the same thing a few years ago. Powered the amp right up sub couldn't handle the power and then all of a sudden no more bass and a burn smell. Took the sub out and stank inside the magnet behind the sub.
 

·
Registered
nissan/patrol
Joined
·
45 Posts
Discussion Starter · #8 ·
thanks for the replies, sorry about the late responses, turns out it was my sub, i burnt out the coil, i noticed sparks, smoke and a potent smell this weekend while at double island with a few mates, we had it cracking, so yeah, time for a new sub.
 

·
After Monday and Tuesday, even the calender says W
06 Td42ti coil cab chassis
Joined
·
18,839 Posts
thanks for the replies, sorry about the late responses, turns out it was my sub, i burnt out the coil, i noticed sparks, smoke and a potent smell this weekend while at double island with a few mates, we had it cracking, so yeah, time for a new sub.
Get your self a Digital Desighns sub.
They do require a fairly large ported box, but they are a very loud sub and can take alot of punishment.;)
 

·
Registered
nissan
Joined
·
628 Posts
Get your self a Digital Desighns sub.
They do require a fairly large ported box, but they are a very loud sub and can take alot of punishment.;)
oh yeah. DD all the way. but then again i did have 2x9915s dual 1s running on 2xz1a loaded to .25.
cooked the sub and then the amp.
did get 149db tho.
got both fixed.
now run 4x1508s off the z1a=wicked :) :)

anyway your gains are up too high, turn them down to match your HU preout level.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top