Patrol 4x4 - Nissan Patrol Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
G'day all, in regards to the hot start issue, and there have been numerous threads on this, i found that cleaning the maf sensor totally fixed the drama. The patrol is a 99 GU 2.8 turbo diesel. I also did the same clean on a neighbours patrol, same make and model, and he has tried the o ring and plate band aid fix on the injection pump and the problem still persisted ,until the clean up of the maf sensor. It does make sense now, in terms of the engines electrical management, as it works overtime to supply yhe same voltage to the maf sensor as it's covered in oil, dirt, dust and the ecu does not realise and buggers everything up, including oversupplying fuel to injection pump. Hope this helps.:cool: :D
 

·
Registered
1998 2.8GU wagon
Joined
·
3,925 Posts
MAF sensor is the box after the air filter, with the grey electrical connector. Remove it from the hoses and spray with MAF cleaner, available from parts shops. DO NOT undo the 4 screws around the electrical connector or you will wreck the sensor & have to replace it.
If you do a Google search you should be able to find how to test it, I have the details somewhere, but can't find them at the moment.
Motor vehicle Automotive tire Automotive design Gas Automotive exterior
 

·
Administrator
Y2KGUII ZD Wgn
Joined
·
56,204 Posts
Thanks a lot bud.
I will look the product on Amazon for cleaning.
Thanks
CRC Electrical Contact Cleaner works fine for cleaning MAF' and is usually available all over the place.
 
1 - 7 of 7 Posts
Top