Patrol 4x4 - Nissan Patrol Forum banner

1 - 6 of 6 Posts

·
Registered
nissan
Joined
·
15 Posts
Discussion Starter #1
Hi guys.

My Speedo is unfortunately not working anymore. So does the odometer not count anymore.

I noticed, when I drove through puddles and the car got wet underneath, the Speedo worked again for a little bit.

Can u guys tell me where it is located on the GQ 97? It seems to be like an electrical / cable issue.

Had an look underneath the car, but there are a few lines and cables going in and out in some cases. So I'd be happy about detailed description

Cheers

Sent from my Nexus 6P using Tapatalk
 

·
Registered
Joined
·
1,345 Posts
RHS of the gearbox, down the back, you'll see a sender sticking out with a couple of wires (could look like one cable if they are enclosed in plastic sheath). Wires go forward towards the bell housing where there is a plastic 2pin plug where it plugs into the harness, this plug is up high on the top corner of the box just behind the bell housing, it can be a bugger to get at with one hand. Check the wires where they exit the gearbox for damage/fraying.


Sent from my iPad using Tapatalk
 

·
Registered
nissan
Joined
·
15 Posts
Discussion Starter #3
RHS of the gearbox, down the back, you'll see a sender sticking out with a couple of wires (could look like one cable if they are enclosed in plastic sheath). Wires go forward towards the bell housing where there is a plastic 2pin plug where it plugs into the harness, this plug is up high on the top corner of the box just behind the bell housing, it can be a bugger to get at with one hand. Check the wires where they exit the gearbox for damage/fraying.


Sent from my iPad using Tapatalk
Found it and fixed it.
The wire was broken right next to the plug which is somewhere underneath the driver side located.

Thanks a lot. It's working well now.

Sent from my Nexus 6P using Tapatalk
 

·
Premium Member
nissan
Joined
·
5,292 Posts
@geeyoutoo.
Is this worthy of a sticky location?
I would never have thought of that when I had issues with a similar problem on my shorty GQ. For some reason my mind was convinced it was a problem with the cluster or earths. May have already been covered, but I never saw it. I looked pretty hard, just asking. :):)

Franky.:)
 
1 - 6 of 6 Posts
Top