Patrol 4x4 - Nissan Patrol Forum banner

1 - 7 of 7 Posts

·
Registered
nissan patrol
Joined
·
2,133 Posts
Discussion Starter #1
I have been having trouble with the patrol getting it to rev and getting slower and slower. Had to come home in third today, had no guts. I changed the fuel filters around 5000ks ago so did not think it would be them. After checking everything else I looked at the fuel filters tonight and found one (first in line from tank) had these little things in the filter bowl that looked like quarter size slater beetles. also lots of grit, no water though. The diesel was a red colour also, checked tank for rust through pump hole and fine but more little bugs in tank.

Anyone have an Idea what it is or could I have just got some dirty diesel?

Been filling up at same place for years with no problems ( BP Daws rd)

cheers.
 

·
Registered
nissan
Joined
·
11,120 Posts
up here on the coast ive never had any dramas with bp fuel been using it for almost 18 months now.
you dont have anyone who dislikes you and may have put sugar in your tanks??? not sure what that normally looks like but its possible. sounds very weird. ive only ever had that diesel algee stuff grow in my fuel but a bit of diesel power additive helps a treat to kill that stuff.

you may have to completely drain tank/s possibly even remove and clean them right out. backflush the lines, replace both filters and even try clean the little gauze filter in the injection pump(assuming its a 4.2) and refill with clean diesel and imo add a liberal amount of chemtech diesel power when refilling, then bleed and run and see if that makes a difference, hopefully it hasnt blocked the pump or injectors up.
but before you do any of that go the the servo and get a fuel sample asap preferabally in a clear container but a new fuel can would do then check at home but you wanna make sure it isnt dodgey diesel. if it is keep the sample and also collect a sample of the fuel in your tank see if its the same. if so well you have bp by the balls.
when did you fill up last??? and has the problem been there ever since the last fill up??
 

·
The Bear
nissan
Joined
·
2,407 Posts
sounds like you filled from an almost empty diesel tank, or immediately after the truck dumped a load of fuel and stirred all the muck up, although the bowsers are supposed to have a filter in line to stop carp getting through, and on second thoughts, unlikely to have been low tank because the intakes are actually up off the bottom of the tanks and dont pick up muck unless stirred up from delivery dump.

Take a sample back to the servo and make a complaint, because if it is contaminated fuel from the servo, yours will not be the only complaint, might be a free repair and refill in the offing. If it is a "company site" take it, the sample, back to the BP depot and complain there, and lodge a complaint online.

Could someone have "got to you" overnight. Whatever open the sender/inspection -port and inspect drain/clean your tank and fit a new main filter, and follow the instructjions from other posts on here and remove the inlet banjo to the IP and pull and clean out the bronze filter in the pump. and if you can blow back the main supply line from filter to tank. When completed, dose whole system with chemtec or similar on refuelling with clean fuel.
 

·
Registered
nissan
Joined
·
224 Posts
You havnt filled up from an unknown source at all? Construction site tanks or Council yards etc? Sounds very similar to the Algae build up I got when I ran on Bio diesel for a while.

NIssan sell an Algae Treatment that you dump in your tank, and then you need to replace all the filters. Mine was in a Cruiser but I had to remove the in tank mesh filter which was all blocked up with little Black/Dark Green spots. Had no power, wouldnt rev and was stalling. Im not sure if patrols have the mesh filter though.

Bio diesel doesnt look like normal diesel either, not as Dark. Could be why it has a reddish tinge to it.

John
 

·
Registered
nissan patrol
Joined
·
2,133 Posts
Discussion Starter #5
Thanks for all replies, I went back to servo today and filled a new can with fuel from same pump. brought it home and found no problem with the fuel or the colour.
Checked when last delivery of fuel and it was the afternoon before I filled up.
So could be the problem, I dont know.
There is no way anyone could get to my tank without me knowing as gas flap is hooked up to alarm. Have drained tank and changed filters and all ok now, back to its old self.

cheers, Shane.
 

·
Registered
nissan
Joined
·
1,730 Posts
Just curious, if you were asking the servo about the fuel delivery etc, did they offer any explaination about your fuel issue?
 

·
Registered
nissan patrol
Joined
·
2,133 Posts
Discussion Starter #7
No, It was hard enough getting the delivery date. just not interested. Indian run servo, not that there is anything wrong with that.
I seem to have got out of it ok but was mainly interested in A) what was/is it and B) has anyone else come across this.

I have cleaned the tank now, + the fuel lines and filters.
Cleaned all fuel containers, so should be good now.

cheers.
 
1 - 7 of 7 Posts
Top