Patrol 4x4 - Nissan Patrol Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
We have a Y61 Patrol 3.0 DI 2007.

It has a weird problem a few weeks ago we where planning a trip and when we left , it stuttert (is this english)
dropping revs while pressing the gaspedal. It dit not stall, did it at different speeds, some times worse, sometimes less.

We went to the garage and they suspected the air density meter or bad fuel. We emptied half a tank of Diesel
and put the more expensive Diesel from shell in and slowly the problem disappears.

However today we filled it up again with expensive type diesel and the problem is back. So logic tells
me that every time we fill the tank the problem starts. It is to soon to judge if the problem disappears again when
the tank is half full again. But I was wondering if somebody here understands this problem.

After google I am thinking something to do with vacuum maybe or a dirty fuel tank (although in Holland that should not be a problem)

Love to see youre ideas.

Robert
 

·
Registered
NISSAN PATROL Y61 3.0 Di (ZD30) 09/2000
Joined
·
373 Posts
Hello,
I have seen that elsewhere.
There is a valve which allows air to come in the tank when the level of diesel goes down. It keeps a minimum depressure in the tank.
If that valve is stuck, then when your tank is full, the depresure quickly goes up as the fuel is being used.
Try to open the tank when the issue arrise. If you get a big 'pschitt' you've got it. You can also leave the tank not fully closed on a flat road, drive and check that the problem goes away. And fix the valve !
 

·
Administrator
GUII ZD30DI Wgn
Joined
·
44,350 Posts
We have a Y61 Patrol 3.0 DI 2007.

It has a weird problem a few weeks ago we where planning a trip and when we left , it stuttert (is this english)
dropping revs while pressing the gaspedal. It dit not stall, did it at different speeds, some times worse, sometimes less.

We went to the garage and they suspected the air density meter or bad fuel. We emptied half a tank of Diesel
and put the more expensive Diesel from shell in and slowly the problem disappears.

However today we filled it up again with expensive type diesel and the problem is back. So logic tells
me that every time we fill the tank the problem starts. It is to soon to judge if the problem disappears again when
the tank is half full again. But I was wondering if somebody here understands this problem.

After google I am thinking something to do with vacuum maybe or a dirty fuel tank (although in Holland that should not be a problem)

Love to see youre ideas.

Robert
What Phil says is a good place to start, the phttt when you open the cap is a dead giveaway. But I would not expect that to happen immediately after filling, this usually happens after you have done a few K and a vacuum builds in the tank holding fuel back.
Can you give a bit more detail on exactly when it happens and the result? It isn't a limp zone is it, does the Stutter occur at idle or under power? When was the last time the fuel filter was checked? When you pump the primer with engine off does it hold pressure and not go soft after a short preiod?
 
1 - 3 of 3 Posts
Top