Patrol 4x4 - Nissan Patrol Forum banner

1 - 8 of 8 Posts

·
Registered
nissan patrol
Joined
·
22 Posts
Discussion Starter · #1 ·
Hello all MQ/MK ers

My taco seems to not be working any more how do I go about fixing? It's in a Mq 84lwb. Thanks
 

·
The Prodigal Child Has Returned
nissan
Joined
·
7,289 Posts
mate chances are the sender has died, it is found In the front of the injection pump . It is very common. , Due a search you should uncover something more The search feature is your friend
 

·
Registered
nissan patrol
Joined
·
22 Posts
Discussion Starter · #4 ·
I don't rely need one but it would be good to log boost ect at a known rpm. I'm doing another search but I never have much luck. Thanks guys
 

·
Registered
nissan
Joined
·
1,167 Posts
Yeah just two (10mm?) bolts and she's out, 1 or 2 wires coming off it.
 

·
Registered
nissan patrol
Joined
·
22 Posts
Discussion Starter · #6 ·
Found the sucker. She has 1 green 1 blue wire. But I don't think I can get it going again. Is there an after market unit I can fit. Like one of those Fk off big suckers with a shift light like all the cool kids put in there rice mobeals :p
 

·
Master Coalroller
nissan
Joined
·
3,230 Posts
Mine isn't working either '86 SD33. Cheapest I can get a sender for is $103 plus shipping, but I don't know if it's the sender.
 

·
Rust is just natural weight reduction.
1986 SD33T SWB
Joined
·
11,016 Posts
Neither of the tachos in my SD's have ever worked since I've owned them.
Now the L28's tacho is dying too... only works intermittently.

My tacos, however, always work.
 
1 - 8 of 8 Posts
Top