Patrol 4x4 - Nissan Patrol Forum banner

1 - 8 of 8 Posts

·
Registered
nissan
Joined
·
884 Posts
Discussion Starter #1
Okay, TB42 petrol turbo. Just today i have been noticing that my car is low on power, feeling slightly sluggish (when i say slightly i mean only enough so that i would notice it).

The main symptom i can explain is as follows, normally, say on the beach (where i did my test) rev first out, 17psi, and grab second, and it will still get 17 and power on.

BUT TODAY - rev first out, bit laggier to get to 17 but gets there, when it shifts into second it drops back to like 9-10psi and takes a while to get back up to 17 again.

Nothing has changed since yesterday, just fitted a UHF and thats it.

Its like that its just struggling to get power, and the something small is causing it to lag up - causing the lower boost levels.

Does it on the road and yeah feels not as lively as it used to....

Please help.

Thanks you.
 

·
Registered
nissan patrol gq ute y60
Joined
·
3 Posts
has tyre pressure changed beach woudnt be the best place to try also the ground can change so quickly or in ruts out of ruts hard sand soft sand low range high range. better to find a big hill on a sealed road 3rd or 4th gear then watch the boost. had to tell when first and second you will only see for a couple of seconds
 

·
Registered
nissan patrol gq ute y60
Joined
·
3 Posts
check all mufflers c if thay arn't blocked all hose clamps pressure side of turbo and if running intercooler could be a hole. air filter/s blocked sorry about the last msg i did fully read the first post
 

·
Registered
nissan patrol
Joined
·
2,006 Posts
Yeah, sounds like a boost leak. Will still get full boost but you lose volume. You will need to go through all your plumbing between the turbo and your intake and look for a leak.
 

·
Registered
nissan
Joined
·
884 Posts
Discussion Starter #5
Yeah thanks will check that today - just seems slack for revving as quickly as it used to.
 

·
Registered
nissan
Joined
·
884 Posts
Discussion Starter #6
The perfect wording for it is that it doesnt snap on as hard as it used to. Still gets full boost though at the higher rpms.
 

·
Registered
nissan
Joined
·
884 Posts
Discussion Starter #8
Nah brand new filter.

People have been saying that BP been selling bad fuel of late, might be a problem, however i ran some octane booster and cleaner through.

Will have to see. Going to drive it to towoombah soon and get terry to have a chop.
 
1 - 8 of 8 Posts
Top