Patrol 4x4 - Nissan Patrol Forum banner

1 - 4 of 4 Posts

·
Registered
nissan
Joined
·
24 Posts
Discussion Starter #1
Hi guys our tb42 swb is duel fuel with a LRA fuel tank. The car is no longer running a mechanical fuel pump and had a "silverline" electric fuel pump on there that was very noisy running on petrol. I assumed the pump was on it's way out so purchased a facet pump (4-7psi) and swapped them over tonight but the noise still remains!!!!!

I am now thinking it has something to do with how the pump is mounted to the chassis. I say this because I played around with the way I mounted the new facet pump and the noise reduced. I had it bolted to the bracket on the chassis with just one bolt instead of two.

Any suggestions on ways to reduce the noise when bolted to the car? I am using spring washers on both bolts. I was thinking maybe a thin strip of dynamat?

Sam
 

·
"Remember, you're unique... just like everyone els
nissan patrol
Joined
·
1,593 Posts
I have the same pump transferring fuel from my AUX tank to my main on my GQ. It's mounted to the floorpan of the body. I did this mainly for the fact that when these pumps run dry it makes one hell of a noise and I know the AUX tank is empty and I can turn off the pump.

So on that idea maybe:

- your pick up from the tank is partially bloked
- a filter is partially blocked
- a hose is kinked
- the breather on the tank is blocked not allowing enough air into the tank to replace the fuel

That's pretty much all I can think of that's caused me drama's, besides an empty tank that is LOL

Let us know how you go!
 

·
Registered
nissan
Joined
·
24 Posts
Discussion Starter #4
Thanks for the suggestions guys. I have to drop the tank because the fuel gauge is reading incorrectly so I'll inspect the pick up and check for blocked/kinked
hoses. I replaced the fuel filter from the petrol tank last week and the one in the engine bay a few weeks ago so can't see the filters being an issue.
 
1 - 4 of 4 Posts
Top