Patrol 4x4 - Nissan Patrol Forum banner

1 - 5 of 5 Posts

·
Registered
TD42 converted GU
Joined
·
127 Posts
Discussion Starter #1
Trying to get cruise control working on my TD42/manual converted series 1 TI GU. The patrol was originally fitted with a TB45 and auto transmission and since the conversion I have also removed both the TCU and ECU.

I have adapted the cruise control throttle cable to the td42 injector pump

I can hear the cruise control hold relay energise when I push the 'Cruise' switch on the dash but I am unable to set a speed, with the steering wheel controls, and the cruise light in the dash cluster does not come on.

from looking at the wiring diagram there only seems to be one link between pin 12 on the Cruise Control Module (CCM) and pin 24 the TCU that could stop it functioning. Everything else should have remained connected as it was before the conversion, as the only other inputs are from the instrument cluster and brake switch.

My 'guess' is that the CCM/TCU link must be a Park/Neutral lockout so cruise control is disengaged when Neutral or park is selected, and that is what is stopping my cruise control from working.

I'd like to confirm the purpose of pin 12 on the CCM and what voltage/signal it is before I start bridging wires.
Does anyone have a Pinout of the TB45 TCU that labels what each pin is for? or does anyone have an idea if pin 24 on the TCU is just a digital 12v signal?
 

·
Registered
TD42 converted GU
Joined
·
127 Posts
Discussion Starter #4
Thanks everyone, was barking up the wrong tree with pin 24, yendor's diagram clearly shows that its purpose is to drop OD when pushing the 'accel' button, and there is a park/neutral lockout relay that i had already bridged out earlier. Anyway managed to sort it out after studying the diagram some more, turns out there is a second brake switch that drops out cruise control that i must have forgot to plug in when i changed the brake pedal assembly to the narrower manual transmission type. After plugging in the second brake switch, cruise control works perfectly, and oddly enough john, the cruise lamp still comes on as it always did previously.
 

·
Registered
Joined
·
1 Posts
Thanks everyone, was barking up the wrong tree with pin 24, yendor's diagram clearly shows that its purpose is to drop OD when pushing the 'accel' button, and there is a park/neutral lockout relay that i had already bridged out earlier. Anyway managed to sort it out after studying the diagram some more, turns out there is a second brake switch that drops out cruise control that i must have forgot to plug in when i changed the brake pedal assembly to the narrower manual transmission type. After plugging in the second brake switch, cruise control works perfectly, and oddly enough john, the cruise lamp still comes on as it always did previously.
Hi I’m trying to do the same thing. Where would I find the park/neutral lockout relay thanks.
 
1 - 5 of 5 Posts
Top