Patrol 4x4 - Nissan Patrol Forum banner

1 - 6 of 6 Posts

·
Registered
Nissan Y60td42
Joined
·
53 Posts
Discussion Starter · #1 ·
So I have a TD42 with 168k kms and it's been using about a liter of oil to every 2000km. Some say it's too young to use oil and maybe I should switch to Delo400 and it will revive the oil springs.. is this true? One more problem is everytime it's cold it starts in one go and idles ok for about a minute then idle drops and eventually it stalls and takes time to start.. when it starts there's some smoke and it seems to be missing but when that phase of about 3 minutes is over its fine all day... what could be the problem I have fitted new original primer pump and filter.. should I have my injector serviced or do I have to touch my pump? Thanks in advance.
 

·
Registered
Joined
·
3,612 Posts
A litre of oil every 2000 k is not overly excessive, as for your stalling it sounds like air in the system. Check all of your hose clamps for leaks and tightness. Has this problem surfaced since a service or filter change ?
 

·
Registered
nissan
Joined
·
2,406 Posts
Injectors are a lot cheaper than pump so start there. They should be refurbished every 100k so you might be well overdue.

A compression test is a very easy an inexpensive health check.

Try using a different oil...make sure it's not newer than CF4...I prefer genuine Nissan oil.
 

·
Registered
nissan gu
Joined
·
355 Posts
Possible, mine was using about a liter over 5000 changed to Rimula X and it stopped using oil

You are getting air in the system that's the most likely reason for the stall
 
1 - 6 of 6 Posts
Top