Patrol 4x4 - Nissan Patrol Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
131 Posts
Discussion Starter #1
hi im a bit worried lately from a knocking noise coming from my gq it made it a few weeks ago and i got it checked out, they did the tappits, clearances and compression tested it for me everything was good. but recently the noise has come back it sounds to me like some sort or bearing, sounds like it might be coming from harmonic balancer area? and sometimes you cant hear it untill you put load on the steering wheel wtf? the car drives like a dream no lack of power or anything, just wondering if anyones has any ideas of what it could be maybe someones come accross this before, any help appreciated..
 
nissan patrol y60
Joined
·
433 Posts
Check ur fan belts had an apprentice at dealership once diagnose a telstra gq as stuffed motor i thought the same when i heard it when he removed belts i seen a big crack in one so run engine without belts and knock was gone sounded like a bigend could of been an expensive stuff up lol.
 
nissan patrol y60
Joined
·
433 Posts
Balancer tight how long has it been doing it. What about idler pulleys did u check them when doing belts.does it knock when revved or when
 

·
Registered
Joined
·
131 Posts
Discussion Starter #6
ahk no i didnt chek idler pulleys, would the water pump nock? its not heating up at all and it only nocks at idle when reving you cant hear it? what should i do to check?
 

·
Registered
Joined
·
131 Posts
Discussion Starter #7
and its been nocking like this consistantly for 3 days now, does accasionaly go away for a short period of time..
 

·
Registered
Joined
·
131 Posts
Discussion Starter #9
ok thanks mate will it be hurting it driving it if it is this? and how do you check that i havet done it before
 
nissan patrol y60
Joined
·
433 Posts
Considering u said sometimes u cant hear it till u move steering id go straight to that pull belt off feel bearing for movement spin it and listen to it even try running it without belts see if goes away or still there
 

·
Registered
Joined
·
131 Posts
Discussion Starter #12
ok no worries ill pull the belts off tomorro and check idler pulley for movement and i did actually notice yesterday a slight bit of coolant leaking from the waterpump seal could this be the problem? if it was the waterpump could it still be stuffed if motor is not heating up?
 

·
Registered
Joined
·
131 Posts
Discussion Starter #13
and ok thanks grubbies i really hope that is all it is are the bearings hard to change in the idler pulley?
 
nissan patrol y60
Joined
·
433 Posts
Yep if its leaking water she ****ed , bearing poss collapsed causing seal to leak. Pump would still operate as per normal will not overheat till it gets low on water which will happen. If already leaking from pump i wouldnt recommend driving it far at all.
 

·
Registered
Joined
·
131 Posts
Discussion Starter #15
okay thanks heaps for your help fallas ill get a new waterpump and check idler pulley hopefully fixes my problems it was the slightest of leak from the waterpump i wiped it and it hasnt seemed to leak anymore but it must be stuffed if it leaked in the first place.. could i check anything on the harmonic balancer to make sure?
 

·
Registered
nissan patrol
Joined
·
2,099 Posts
ok no worries ill pull the belts off tomorro and check idler pulley for movement and i did actually notice yesterday a slight bit of coolant leaking from the waterpump seal could this be the problem? if it was the waterpump could it still be stuffed if motor is not heating up?

Ummmmm, probably the first thing ya shoulda mentioned.:rolleyes: i'll put ANOTHER Corona on that!
 

·
Registered
Joined
·
3,955 Posts
good you solved it, just in case others use this thread for reference in future heres another thing to check:

lower outer bolt on power steering pump, where it pivots when adjusting. This can wear if loose and become offset, parts of the bolt become oval allowing the pump to tilt and move around.
 
1 - 18 of 18 Posts
Top