Patrol 4x4 - Nissan Patrol Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
572 Posts
Discussion Starter #1
Having a problem with my 12 000lb TIGERZ11 winch I purchased in November last year.

Tried my winch today to see if its all good for cruiser park over easter, all i got was a click everytime i pressed in or out.

any ideas? anyone else had the same problem?

what should i do about the situation?
 

·
Rogue
nissan gu patrol
Joined
·
20,220 Posts
Well the clicking could be the soleniods so the control box might be alright. I would pull the motor off and give it a clean particularly the commutator.
Does the clutch still disengage and can you pull out the rope/cable (even just a little bit to rotate the drum)
 

·
Registered
nissan
Joined
·
436 Posts
Before you pull anything apart check your earths and power leads also check that the control box is earthed as well as they will not work without that, it may just be a poor connection somewhere
 

·
Registered
Joined
·
963 Posts
how bout you contact Paul [email protected]
or the dealer you bought it from. If its that young it should be covered by warranty, Paul has shown in the past he is more than happy to back up his product with the service you expect from a major manufactuer much less a family business.
 

·
Registered
Joined
·
572 Posts
Discussion Starter #10
how bout you contact Paul [email protected]
or the dealer you bought it from. If its that young it should be covered by warranty, Paul has shown in the past he is more than happy to back up his product with the service you expect from a major manufactuer much less a family business.
first thing i did was contact paul. but without sending the unit to him its unrepairable.
I just want to try and get it working for the weekend, if it costs me so be it.. But something like this should be a direct replacement or swap and i had no luck with that..
 

·
Registered
nissan patrol
Joined
·
54 Posts
if its buggered, the new tg thompson solenoid they selll works well, and i have not been able to get water inside mine at all.
 

·
BORDERTREK 4X4 & FABRICATION
Joined
·
8,549 Posts
I dont know why they just dont come standard with the Thompson kit. I'm sure people would be willing to pay the little extra money and it would put a stop to all this mucking around with warranty that both parties have to do.
 

·
Rogue
nissan gu patrol
Joined
·
20,220 Posts
So what is the clicking sound?
 

·
Registered
nissan
Joined
·
14 Posts
I had a simular issue with mine. It was 11months old so assumed that it would be covered by the '3year warranty'.
The distrubitor couldn't have been less helpfull, saying that the electrics were only covered for 6 months!! I'd tested it the driveway once!!

In the end I pulled the solenoid apart myself and found a wire that had a dodgy solder from factory. Fixed it up, and all good, just a bit dissapointing in terms of support.

It wasn't that hard to have a look inside of the solenoid, might be worth a go.
 
1 - 14 of 14 Posts
Top