Patrol 4x4 - Nissan Patrol Forum banner

41 - 42 of 42 Posts

·
Registered
Joined
·
9 Posts
After all the mucking around I have finally got my patrol running . Pulled another injector pump off my old engine . Hooked it up and spun it with a drill, it was constantly pumping fuel even without ignition or powered . Thought somethings not right there . Got my hands on another pump tested it, all ok working as it should . Fitted it to car today and I’m back up and running . Morale of the story bench check your pumps before hand . After 3 pump failures I was still searching for something else . Just goes to show how **** these pumps are . Buy new or make sure you test them before install!
 

·
Administrator
Y2KGUII ZD Wgn
Joined
·
48,194 Posts
After all the mucking around I have finally got my patrol running . Pulled another injector pump off my old engine . Hooked it up and spun it with a drill, it was constantly pumping fuel even without ignition or powered . Thought somethings not right there . Got my hands on another pump tested it, all ok working as it should . Fitted it to car today and I’m back up and running . Morale of the story bench check your pumps before hand . After 3 pump failures I was still searching for something else . Just goes to show how **** these pumps are . Buy new or make sure you test them before install!
Good you got it sorted, but they are actually quite a solid pump that perform quite well and have been fitted to many different engines by different manufacturers, air is their greatest enemy. I got 370,000k out of mine no worries, fitted a reputable 'rebuild' myself and it is performing brilliantly as well.
There must be concern about the history of the pumps you had that failed.
 
41 - 42 of 42 Posts
Top