Patrol 4x4 - Nissan Patrol Forum banner

1 - 6 of 6 Posts

·
Registered
nissan patrol
Joined
·
16 Posts
Discussion Starter #1
Hi guys , missus just got back from dropping kids at school and I noticed steam from under the bonnet . I checked the temp guage and it was in between 3/4 and full which it never gets over half normally .I could hear it sizzling and found a leak here . Not sure if it's the little hose running straight up and down or the metal pipe but would probably like to replace both . Any idea on part numbers or name ?

Cheers , Jake
15821555270967258079821900553585.jpg
 

·
Registered
nissan
Joined
·
254 Posts
I think it goes to the throttle body to keep it warm, by the looks of things it long overdue for replacement( maybe the other hoses that are under the inlet manifold need attention too). From my experience if the temp gauge moves over half you have overheating issues, radiator and or viscous hub?


Sent from my iPhone using Tapatalk
 

·
Registered
nissan patrol
Joined
·
16 Posts
Discussion Starter #3
Cheers mate , I'll re assess on Sunday when I get home . I followed that line and it looked to go on to the oil cooler ? Might be worth re placing the radiator anyway . I brought it with 235k on it and who knows if how it's ever been replaced before .
 

·
Registered
nissan patrol
Joined
·
16 Posts
Discussion Starter #4
Finally got a chance to look at it . All those hoses are shagged so need to be replaced . Dropped coolant from radiator and found 3.5ltrs of brown watery looking **** . Opened the cap and it looks brown and rusty too :( . Filled her up with water and it took on 9 ltrs. Now I can see it leaking out the front top of the motor almost behind the dizzy . Think I might have to limp it to the mechs as might be more than radiator
 

·
Registered
nissan patrol
Joined
·
16 Posts
Discussion Starter #6
Ended up being a Welch plug . Replaced every hose aswell as the metal one .
 
1 - 6 of 6 Posts
Top