Patrol 4x4 - Nissan Patrol Forum banner

1 - 18 of 18 Posts

·
Registered
nissan
Joined
·
15 Posts
Discussion Starter · #1 ·
Had my GUII (3.0TDI) die on me yesterday so had it towed to my mechanic. Report comes back this morning its an injector pump.

Mechanic (who's also a member here) tells me around 10 hours work to get in there and change over and all up looking around the 3-4k mark

Are there any other options? replacement motor, rebuild/rebuilt something-or-other? 2nd hand seems like a bad idea with so much labor.

4k is a lot of coin so looking for ways to make sure this is done right.
 

·
Registered
Joined
·
2,837 Posts
one thing to check is that it is actually the IP at fault. seen plenty of cases where a so called faulty IP was infact a blocked up filter or air being sucked into fuel line.

ie how do they know its the IP thats failed?
also what part of the IP failed? if its the IP ECU it can be repaired. what part has failed can point to WHY it failed eg fuel contamination.
 

·
Go Hard or Go Home
Joined
·
3,197 Posts
Had my GUII (3.0TDI) die on me yesterday so had it towed to my mechanic. Report comes back this morning its an injector pump.

Mechanic (who's also a member here) tells me around 10 hours work to get in there and change over and all up looking around the 3-4k mark

Are there any other options? replacement motor, rebuild/rebuilt something-or-other? 2nd hand seems like a bad idea with so much labor.

4k is a lot of coin so looking for ways to make sure this is done right.
Sorry to hear the bad news mate,

a new Ip will set you back between 5-5.5k

Is this mechanic from Rockhamton?

Anyone thought of one of these from the US? don't know if they are suitable though with a different backing plate for the injector lines?
DODGE VP44 DIESEL FUEL INJECTION PUMP 98 99 00 01 02 - eBay (item 120614396369 end time Dec-25-10 12:52:06 PST)
 

·
Registered
nissan
Joined
·
15 Posts
Discussion Starter · #4 ·
Nah, in Adelaide.

Whilst he usually works on it for me, he hasn't done this particular job before so would be outsourcing it. He has gotten two opinions based on the code read outs.

1 readout suggests no communication with the IP
2nd readout suggests no spillover???

The two shops he spoke to both agreed this was likely an IP replacement.
 

·
Registered
Joined
·
2,837 Posts
get the codes off him.

the dodges pumps won't work as they are 6cyl motors.
 

·
Cruisin for a bruisin
Joined
·
1,732 Posts
Sounds more like a plug to the IP ECU to me unless you have had the filter replaced and the system wasn't bled and then it'll be the IP ECU which has fried itself..
 

·
Registered
Nissan GU
Joined
·
140 Posts
Sounds more like a plug to the IP ECU to me unless you have had the filter replaced and the system wasn't bled and then it'll be the IP ECU which has fried itself..
Not to sound stupid but apart from priming with the hand pump, what is the correct way to bleed the system if you change the fuel filter?
 

·
Registered
nissan
Joined
·
15 Posts
Discussion Starter · #9 ·
Here is what they wrote down

74 p4 spill valve ckt (that bit is unreadable)
73 p3 pump communication line
76 p6 spill valve

I mentioned the idea of the IP connection plugs and the he'd tried that.
 

·
Registered
nissan
Joined
·
15 Posts
Discussion Starter · #11 ·
They're telling me about 3k for an IP + 8-10 hours labor for a total of 3.5-4k. Does this sound reasonable?

i've also got oil in the corners of my intercooler - should I be looking to do something about this at the same time?

I have purchased a dawes valve, but haven't fitted it yet. Was going to wait until I had the e something something sensor and boost control gauge. Thinking I'll spring for this at the same time all this is happening.

Its done around 210,000km and runs really well so keen to keep it - should I be thinking sale or it this just normal wear and tear?

ramble over :D
 

·
Autos are Superior
Joined
·
11,701 Posts
Doing everythin at once is probably a really good idea, inc gauges, dawes, blocking EGR etc etc...

hard part is if your surname is not Packer :(
 

·
Registered
nissan
Joined
·
1 Posts
Rcon, did you get to the bottom of this?

I've just had my nissan work car turn up it's toes with the same codes. Initially it was running:
Code 43: Accel Pos Sensor (17 starts)
Code 73: P3-Pump Comm Line (0 starts)
Code 76: P6-Spill Valve (2 starts)

The accel pos sensor is a red-herring.

After clearing and cranking (no start) I get.
Code 73: P3-Pump Comm Line (2 starts).

I'm trying to nut out if this really is a communication error (i.e. wires) or whether the pump control board is rogered. I do have a spare pump, of unknown condition but my engine is in sideways and it will be easier to drop the engine out to fix it than attempting to remove the pump in-situ.
 

·
Registered
Nissan Patrol GU
Joined
·
1,210 Posts
Im having the same problem here, code 73 P3 pump comm (24) what does that suppose to mean? Pump on way out?
Cheers
 

·
Registered
nissan
Joined
·
365 Posts
I had my pump rebuilt a few weeks ago, it cost $2.5K the engine was already out for the rebuild.

a $3-$3.5K is a reasonable price for the rebuild as there's a fair bit of work to pull it out.
 

·
Elmo
Nissan
Joined
·
4,899 Posts
Ah a thread has already been created for it.

Well I never thought I'd hear myself say this but I am almost a victum of the elledged ZD30 IP.

I paid BusaKaine (Kaine) a visit at his humble aboad last night to run ecu talk on my GU. dun dun dun

ECUTtalk Results:
Code 71: P1-Cam Pos Sen (11 starts)
Code 42: Fuel Temp Sen (11 starts)
Code 74: P4-Spill/V Circ (11 starts)

Checked the manual and they all point back to the injector pump. So I've started the car 11 times since this error occured. I'm going to Fraser this weekend and will buy an ECU talk tonight so I can check it myself. I will see if the error re-occurs. If so. I'm not taking any risks and I want to get this pump done asap.
 

·
Elmo
Nissan
Joined
·
4,899 Posts
It all started I'm certain after I turned the car over for a split secon without glowing the injectors. then tried starting it then it would just turn over. remove the key glow the inectors, bam starts first go.

That's the story of when my error code started.
 
1 - 18 of 18 Posts
Top