Patrol 4x4 - Nissan Patrol Forum banner

1 - 3 of 3 Posts

·
Registered
nissan
Joined
·
52 Posts
Discussion Starter · #1 ·
Hey well on friday i changed my fuel filter and after starting it it was running really rough and blowing white smoke for about 2 mins after smoke stoped turned the car off and started it again, it started fine and no smoke but after leaving it for 10 min turned off and starting it again it would start rough and blow smoke. so i got on the net looked up what was wrong and found some one saying ryco fuel filters are no good on ZD30 so i put a post on here asking about ryco fuel filter and i got told it air geting in not the filter so all day sunday i was looking for leaks and found nothing. started the car monday for work and same thing rough and smoke so being worried about it i got a lift to work with my brother, after work came home and tryed starting the patrol locked and water under the car. starting to pull it down not sure if its head or blown head gasket we shall see. no signs before running rough and the smoke,didnt get hot no loss in power nothing. oh well just my luck thats my life lol.
 

·
Autos are Superior
Joined
·
11,701 Posts
Hey
Well on Friday I changed my fuel filter and after starting the patrol it was running really rough. It was blowing white smoke for about 2 mins after smoke stopped turned the car off and started it again. It started fine and no smoke this time. But after leaving it for 10 minutes, I turned it off and starting it again.
It would start rough and blow smoke.

So I got on the net, and looked up what was wrong. I found someone saying ryco fuel filters are no good on ZD30. So I put a post on here asking about ryco fuel filter and i got told it maybe air geting in not the filter.

So all day Sunday, I was looking for leaks and found nothing. I started the car Monday for work and same thing - it ran rough and blew smoke. So being worried about it, I got a lift to work with my brother.
After work I came home and tryed starting the patrol I looked underneath the patrol saw water under the car. (I assume thats what hes trying to say)

I starting to pull it down. I am not sure if its head or blown head gasket we shall see. No signs before running rough and the smoke, didnt get hot no loss in power nothing.
Oh well just my luck thats my life lol.
Any chance you could at least attempt to make your **** readable?

Did you run the car and see if you could see where the water was coming from? I cant see the fuel filter change making it leak water.

Did you try changing fuel filters from the Ryco to Genuine or similar and bleeding the system properly before dismantling the engine? My GQ did similar until I bled the system properly after changing filters..
 
1 - 3 of 3 Posts
Top